Guide :Optics : DS-2130 (350 x 127mm) Telescope

I have six Meade ETS-LX 6" telescopes which are used in an introductory astronomy lab. I have upgraded the firmware and other files in three of the six and they are working fine. The other three do not function properly. When the powerswitch is turned on, the light in the switch blinks several times and then comes on steady. The AutoStar III handbook shows nothing. I tried the Safe-Loader method given in the advice in several places (including this site) to restore the functioning (hold Enter and Scroll down keys and then turn on), but that does not work (I think it only applies to #495 or #497 Autostars). The safe load procedure for the Autostar II also (999) does not work. According to the Meade assistance person I spoke with, there is no safeload procedure for the Autostar III. The handboxes are not the problem, they work fine on the three telescopes that I did get working. None of the working telescopes give the blinking on the power switch common to all three that do not work. I have tried turning the telescopes on using battery power only, and with the Meade approved 12 V power converter: same sympton with both. Meade's advice is to mail the telescopes to them. If it was only one that failed in this manner I'd probably take that advice, but with three failing the same way, I thought I try to get some help. All are out of warranty, of course. Any ideas?

Posted by johncampb694 on Mar 07, 2011

Research, Knowledge and Information :



We did not find results for: i have six meade ets lx 6 telescopes which are used in an introductory astronomy lab i have upgraded the firmware and other files in three of the six and they are working fine the other three do not function properly when the powerswitch is turned on the light in the switch blinks several times and then comes on steady the autostar iii handbook shows nothing i tried the safe loader method given in the advice in several places including this site to restore the functioning hold enter and scroll down keys and then turn on but that does not work i think it only applies to 495 or 497 autostars the safe load procedure for the autostar ii also 999 does not work according to the meade assistance person i spoke with there is no safeload procedure for the autostar iii the handboxes are not the problem they work fine on the three telescopes that i did get working none of the working telescopes give the blinking on the power switch common to all three that do not work i have tried turning the telescopes on using battery power only and with the meade approved 12 v power converter same sympton with both meade s advice is to mail the telescopes to them if it was only one that failed in this manner i d probably take that advice but with three failing the same way i thought i try to get some help all are out of warranty of course any ideas.

Suggested Questions And Answer :


I have six Meade ETS-LX 6" telescopes which are used in an introductory astronomy lab. I have upgraded the firmware and other files in three of the six and they are working fine. The other three do not function properly. When the powerswitch is turned on, the light in the switch blinks several times and then comes on steady. The AutoStar III handbook shows nothing. I tried the Safe-Loader method given in the advice in several places (including this site) to restore the functioning (hold Enter and Scroll down keys and then turn on), but that does not work (I think it only applies to #495 or #497 Autostars). The safe load procedure for the Autostar II also (999) does not work. According to the Meade assistance person I spoke with, there is no safeload procedure for the Autostar III. The handboxes are not the problem, they work fine on the three telescopes that I did get working. None of the working telescopes give the blinking on the power switch common to all three that do not work. I have tried turning the telescopes on using battery power only, and with the Meade approved 12 V power converter: same sympton with both. Meade's advice is to mail the telescopes to them. If it was only one that failed in this manner I'd probably take that advice, but with three failing the same way, I thought I try to get some help. All are out of warranty, of course. Any ideas?


These scopes have many bugs in the firmware and are not a mature technology. Some people have issues and some do not.About the only thing you can try is to reload the firmware using the SC CARD method. Contact Meade or read the manual to learn how to upgrade the firmware using an SD flash memory card.Other than that the scopes will need to be returned to Meade for repair.
Read More At : DS-2130 (350 x 127mm) Telescope...

MEADE TELESCOPE hi there please could you help me i bought a meade etx-105ec astro telescope but when i plug in the autostar it doesnt seem to be sending power to the hand set ,i changed batteries tryed to reset but still nothing ? hope you can help thank you


With the power off, check the connectors are properly plugged in at both ends. Like a network cable, the clip bit should spring out when properly located. Then power on. Within a couple of seconds there should be a long bleep and the display will show a startup message ( A U T O S T A R and Version number). If that doesn't happen, and the batteries are fresh (and inserted the right way round), try connecting the curly cable the other way round (apparently that sometimes fixes it - personally I reckon it may just give another chance to plug it in correctly). If the doesn't work, you may have a faulty cable or a faulty Autostar or a faulty control panel. Take it back to the reseller to sort it out!
Read More At : ETX-105EC (420 x 105mm) Telescope...

I have a Meade ETX-70AT scope that I inherited from a neighbor years ago. It came with two eye pieces (9 and 25 mm), a tripod, and an Autostar which I believe is the #494 model. On the bottom of the Autostar, there are no ports for cables and only the coil cable going in (no way to remove it without cutting it). When I plug it in, even with fresh batteries in the scope, and turn on the power, I only see one row of LCD squares, occasionally two, and every once in a great while it lights up red. I usually try it when indoors where I can see what I'm doing, and I am at a loss for what to do, other than break it open and try to fix it myself. Thanks in advance, Alex


The hand controller cable is probably defective-- right at the connector that plugs into the scope. Any computer network "wizard" can replace the connector. The wires must be in the exact same sequence when he repairs it.If this simple fix does not work and you KNOW that the batteries are good-- then the hand controller is defective and will need to be replaced.
Read More At : 494 AutoStar Telescope Control Unit (Handbox only)...

Meade LX200GPS 8" won't initialize on power up.


Try doing either a garbage collect or a safe load-- and then reinstall the hand controller firmware-- Instructions-- depending on the type of controller Autostar 495 or 497: You enter Safe Mode by holding the [enter] and[scroll down] keys pressed when you power up the telescope. TheAutostar will say "Flash Load Ready"... now go start the ASU.Autostar II: if you need to use Safe Mode to recover from a disaster,turn on the telescope, and key 999 before it says "Initializing"The Autostar will say "Flash Load Ready"... now go start the ASU.LX200gps: BEFORE proceeding further, click on the OPTIONS item on the Top Bar. Now click on "Garbage Collect Hbx" ... this will perform data cleanup within the Autostar which will avoid potential mess-ups.
Read More At : LX200GPS Telescope...

Meade ETX 70 telescope won't turn on regardless of power source


Dead on arrival! Meade can fix these, but they must be shipped back to the factory.Here is their customer service web site:http://www.meade.com/support/index.html
Read More At : Meade...

MEADE ETX 125 Motors have stopped


The ETX125 is notorious for bad motor control. Weasner's Mighty ETX web site has links to repair centers that are more reasonable than Meade. They also have a QA section to assist with diagnostics.
Read More At : ETX-125EC (500 x 127mm) Telescope...

I have an older Meade LX200 GPS with autostar II handset. The telescope was working fine and last night I got an error message on the handset "Error: Inv. Heap" and the telescope locks up with no further handset or RS232 communications working. I powered the telescope down. When the telescope powered back on, I got the welcome to Autostar message and the firmware version 4.2g. It then changes to a message "Reorganizing" and then generates the Error: Inv. Heap". Meade says to "Reset" but the system locksup before getting to that point in the bootup. Any input on how to resolve this problem?


You may have Corrupted firmware in the hand controller- that's why they want you to do a RESET.You might have to reload the correct firmware to fix this problem.I believe if you hold down the ENTER KEY and the SCROLL DOWN arrow key and then turn on the scope you enter SAFE LOAD where you can reload the firmware.
Read More At : Meade...

I have an issue on my meade ET90 AT. I have a motor failure message after the telescope try to find a star. Now when I turn on I received a message from the autostar to press 0 or mode in both case it start the test motor and appear the message Motor fault. I change the batteries but it doesn't change the result. When I turn on and I received the message "0 or press mode" if I try to push the arrows button the telescope move right and left but no up and down. I called the meade customer service and after 30 seconds they told me to bring the telescope to their repair center. Thanks


Try this.1. Do a RESET on the hand controller.2. Reenter your Site, Date, and Time.3. Calibrate MotorsNow see if that fixed it. If not it will need to be returned to Meade because a gear or circuit is broken inside the scope.
Read More At : ETX90AT Maksutov Telescope with UHTC (cat35140321)...

ETX-125 Autostar controller not working


My ETX 125 did this to me, here's what happened I had a 497 autostar hooked up to it and it quit working the scope stopped dead and the autostar went dead i hooked another autostar up to it and the same thing happened I took the scope apart and noticed that the wires for the upper motor run through the bolt that tightens the rotational clutch on the base, the clutch handle mechanism in the base sliced through the wiring and shorted out the 12v black wire onto the autostar data yellow wire, this sent 12v back into the autostar and fried it. both autostar circuit boards were destroyed as the short caused the custom programmed microchip to burn and blister. I am in the process of repairing mine and getting a new autostar computer. I would recommend against asking a friend to try thier autostar box on your scope for obvious reasons.
Read More At : ETX-125EC (500 x 127mm) Telescope...

Best out of 3 Telescopes


Hi Glenn I would recommend the DS2000 should be DS2114 AT. The ATrefers to the use of the autostar hand box. This is a helpful tool for the beginner. Once you learn how to align the scope the computer will guide you around, helping you become familiar with the orientation of objects in the sky.
Read More At : Polaris 114EQ-D (36 x 114mm) Telescope...

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.
next Question || Previos Question
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.opticinfobase.org || Terms of Use || Contact || Privacy Policy
Load time: 0.0612 seconds